
  

 
2017 Knowledge Based AuditsTM of Governmental Entities 

May 2017 

CCH® ProSystem fx® Knowledge Coach 

Welcome to 2017 Knowledge-Based AuditsTM of Governmental Entities for Knowledge Coach 

This Release Notes document provides important information about the 2017 release of Knowledge Based Audits TM of Governmental 
Entities. Please review this information carefully. If you have any questions, additional information is available on CCH Support Online. 

New in this Release  

Knowledge-Based Audits of Governmental Entities  
It is designed to help the auditor efficiently and effectively perform financial statement audits of state and local governments in accordance 
with auditing standards generally accepted in the United States of America (U.S. GAAS) and generally accepted government auditing 
standards (GAGAS). The knowledge-based audit is a risk-based methodology that emphasizes using knowledge of the entity to make risk 
assessments in connection with financial statement audits.  

The operations of governmental entities are often unique and complex and require specialized accounting and auditing knowledge. This 
edition includes specific up-to-date guidance for auditing state and local governmental entities.  

Conducting audits of governmental entities requires the exercise of the auditor’s professional judgment. This document is published for the 
purpose of communicating the updates and enhancements included in the current version to users of the toolset. This document is not, 
and should not be used as an audit program to update the audit documentation of an engagement started in a previous version of this 
product. 

This is the seventh update to this Knowledge Coach title. If you are updating from a previous version of this title, refer to the Knowledge 
Coach User Guide Chapter 12. The guide is found on the Engagement File Room Help menu.  

The 2017 documents include Accounting Research Material links to specific guidance that provides instant access to detailed analysis 
related to the steps and processes discussed in the workpapers.  

2017 edition of Knowledge-Based Audits of Governmental Entities  
This edition features numerous enhancements, including:  

• AUD-903 and AUD-904 streamlining and minimization for duplication elsewhere. Some steps in AUD-903 have been moved to KBA-
501.  

• Reorganizing KBA-105 so the user will add entries to column 1 instead of column 3 to make the flow more logical. 

• Adding new columns to AID-701 which will allow the user to select whether the assertion is relevant or not. For any assertion 
marked as not relevant, the user will NOT need to complete the planned level of control risk. The selections made in this new 
column will flow to other areas of the workpaper. 

• Adding a comments column to KBA-400 Scoping and Mapping Table and in KBA-502 Assertion Level Risk Table.  

• Adding an option for a Not Applicable answer to question 10 of AUD-602. 

http://support.cch.com/productsupport/
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• Adding a new Not Applicable option in KBA-103 column 15, "If Not a Material Weakness, Is It Important Enough to Merit Attention 
by Management?" 

• A new KCO-003 Answer Effects for the Engagement-Level Tailoring Questions Workpaper that will show all answer effects of each 
tailoring question in AUD-100. 

• A new resource document: RES-022 Special Considerations in Auditing Financial Instruments 

Click here for the 2017 Governmental Entities Title Overview for Knowledge Coach Users. 

In addition, forms and practice aids throughout have been updated to include new examples and tips, and where applicable, to take into 
account: 

New literature, standards, and developments, reflected in the following current audit and accounting guidance:  
• SAS-131, Amendment to Statement on Auditing Standards No. 122 Section 700, "Forming an Opinion and Reporting on Financial 

Statements" (AU-C Section 700) 

• SAS-130, An Audit of Internal Control Over Financial Reporting That Is Integrated With an Audit of Financial Statements (AU-C 
Section 940) 

• Government Auditing Standards-2011 Revision (GAGAS) (Yellow Book) 

• GASB Standards and Exposure Drafts up to and including GASB Statement No. 82, Pension Issues – An amendment of GASB 
Statements No. 67, No. 68, and No. 73; 

• Uniform Administrative Requirements, Cost Principles, and Audit Requirements for Federal Awards contained in the 2nd Code of 
Federal Regulations, Part 200 – 2CFR200 

• ET Section 1.295, Nonattest Services, of the AICPA Code of Professional Conduct-Revised; and  

• Guidance in the most recent editions of the AICPA Audit and Accounting Guide, State and Local Governments 

• GASB Implementation Guide Update 2016-1; 

• Statement on Standards for Accounting and Review Services (SSARS) No. 21, Statements on Standards for Accounting and Review 
Services: Clarification and Recodification; and 

• For changes with respect to disclosures related to GASB Standards that are currently in effect or to begin for periods after June 15, 
2016 

Notes: 

• Make sure to save changes to workpapers before closing the workpaper or the binder to ensure data is correctly updated. 

• If your Current Editor Knowledge Coach MS® Word workpapers become read-only or crash, please do the following: 

– Keep the binder with the affected workpapers open. 

– Highlight the workpaper in the binder window and go to Tools > Save Knowledge Coach Answers. 

• As of the December 2016 update to Engagement 7.5 and Knowledge Coach 2.5, you can open binders that contain Knowledge 
Coach workpapers when logged into the Shared File Room (SFR) mode in Engagement with the following restrictions:  

– Knowledge Coach workpapers cannot be edited in the SFR mode. 

– However, Knowledge Coach workpapers can be viewed as read-only, signed off on, and workpaper notes can be written on 
Knowledge Coach workpapers while in the SFR mode. 

– Non-Knowledge Coach workpapers can be edited in SFR mode without restriction. 

https://support.cch.com/updates/knowledgecoach/pdf/guides_tab/2017%20Governmental%20Entities%20Title%20Overview%20for%20Knowledge%20Coach%20Users.pdf
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System Requirements 

• This title MUST be used with CCH® ProSystem fx ® Engagement v7.5 or higher, Knowledge Coach v2.5, and 2016 Financial Statement 
Base v4 or higher.  If you have not installed the Engagement v7.5 and Knowledge Coach v2.5, ensure that you do so before using 
this title. If you are upgrading from Engagement v7.1 or lower, please contact Technical Support. 

• A minimum of 4GB of RAM is required for optimal performance when opening and navigating through Knowledge Coach 
workpapers. 

Download Instructions 

Download the 2017 Knowledge Based Audits of Governmental Entities from the Knowledge Coach Updates section of the Engagement 
Support Website. Then select the Knowledge Coach Series and Download file link next to the 2017 Knowledge-Based Audits of 
Governmental Entities. On some occasions, the content package file (.KCP) will download with the extension changed to .ZIP. If this occurs, 
please change the extension of the downloaded file to KCP using all capital letters. 

You must install the 2016 Financial Statement Base v4 title before installing the 2017 Knowledge Based Audits of Governmental Entities.   

The Financial Statement Base title is also available on the Knowledge Coach Update Website. 

Important: Engagement v7.5 or higher and Knowledge Coach v2.5 must be installed on the computer in order to install this Knowledge 
Coach title. For additional requirements, please review the System Requirements on our CCH Support website. 

The Knowledge Coach Content Package (KCP) download is a proprietary file that must be installed from within Engagement. Save this KCP 
file to a location on your local drive, and follow the Installation Instructions included in the Release Bulletin. 

Installation Instructions 

Once you have downloaded your Knowledge Coach title, you will need to add it to the list of titles within CCH ProSystem fx Engagement. 
The only additional system requirement is approximately 75MB of disk space to store your Knowledge Coach Program content files. Please 
refer to the Engagement with Knowledge Coach Release Notes for any other system requirements.  

 

After downloading the 2017 Knowledge Based Audits of Governmental Entities, do the following: 

1. Launch the Engagement Workpaper Management application so that the Local File Room is displayed. Select Tools > Knowledge 
Coach Titles.  

2. The Knowledge Coach Titles window will be displayed.  

3. Select Add Title.  

4. Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge Coach Support Web site.  

5. Select Open.  

6. The system will display a progress indicator while the title package is added. You will receive a message that the title has been 
successfully installed once the process is complete. 

Note: You can determine this access in the Engagement Admin module by selecting a staff group and File > Properties > Content “Insert 
Knowledge Coach workpapers from unreleased titles” option. 

 

https://support.cch.com/contact
http://support.cch.com/updates/KnowledgeCoach
http://support.cch.com/updates/KnowledgeCoach
https://support.cch.com/kb/solution.aspx/sw46708#Workpaper%20Management%20Module
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To release a title:  

1. Select one of the Knowledge Coach titles in the list that has been added but is not yet released.  

2. Select Release Title. The current date and time will be displayed in the Date released column, and the status will change to 
“Released.”  

Note: In the Engagment Admin module, add and assign a Knowledge Coach module and the applicable Knowledge Coach title license 
before using the workpapers.  

Important: Once the 2017 Knowledge-Based Audits of the Governmental Entities title has been added and released, they will be 
automatically deployed to other staff members when they login to the “Office” location, or when they synchronize a binder that contains 
Knowledge Coach workpapers from this title.  

Online Permission Key 

Permission key files may be downloaded from our website or when adding or updating the new licenses within Engagement Administrator 
with Knowledge Coach v7.5 and higher. After updating the license file in the Engagement Admin module, licenses need to be assigned to 
the staff who will use 2017 Knowledge-Based Audits of Governmental Entities. 

If you have not already established a Single Sign-on (SSO) account with Customer Service, we urge you to do so at this time.  

CCH® Accounting Research Manager® 

CCH’s Accounting Research Manager ("ARM") is the most comprehensive, up-to-date and objective online database of financial reporting 
literature. It includes all authoritative and proposed accounting, auditing, and SEC literature, plus independent, expert-written interpretive 
guidance.  

Available on ARM, the Knowledge-Based Audits of Governmental Entities Guide helps you comply with the most recent professional 
standards and guidance for the conduct of audits of Governmental Entities and to integrate the use of practice aids, tools, and other 
resources with its guidance. This publication supplements and complements the Knowledge-Based documents that are available in 
Knowledge Coach. 

If you subscribe to an ARM library that includes Governmental Entities content, you can link directly to source material from Resources 
within Knowledge Coach documents. These links have been updated to refer to the accounting standards under the FASB Accounting 
Standards Codifications.  Also, if you subscribe to the Knowledge-Based Audits of Governmental Entities Guide on ARM, you can take 
advantage of references to the guide material from within the Knowledge Coach documents.  

With Accounting Research Manager, you maximize the efficiency of your research time, while enhancing your results. Learn more about our 
content, our experts, and how you can request your free trial by visiting the Accounting Research Manager website. You can also access the 
Accounting Research Manager Website by selecting Engagement > Binder Window > Shortcuts Bar > Guidance tab.  

Using Your Knowledge Coach Content 

To use your Knowledge Coach Workpaper Templates, do the following: 

1. Open a binder in Engagement. 

2. Select the workpaper tab into which you would like to insert the workpaper. 

3. Select New Knowledge Coach Workpaper from the toolbar or File menu. 

4. The New Knowledge Coach Workpaper dialog appears (Figure 1).  

https://prosystemfxsupport.tax.cchgroup.com/permkey/download.aspx
http://www.accountingresearchmanager.com/
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5. Select the New Knowledge Coach Title with the content you would like to use. You can only select titles you have installed. The 
information displayed changes to reflect the workpaper organization available for the selected title.  

6. Select the Knowledge Coach Workpapers to insert into your binder and click OK.  

7. In the Selected Workpaper Properties dialog, each workpaper name is automatically loaded into the Name field. Add a workpaper 
index in the Index field and make any Name modifications you desire. You can also modify the tab location or the roll forward 
settings for each workpaper. 

8. Click OK. The integrated Knowledge Coach workpaper is now inserted into your engagement binder.  

Note: For more information on how to use Knowledge Coach workpapers in your binder, see the Knowledge Coach User Guide.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Additional Information on Knowledge Coach and the KBA Methodology 

Knowledge-Based Audit (KBA) Methodology 
Allows the results of one set of procedures to become the input for the next. The key components of the KBA methodology include: 

• An Overview that guides auditors through the methodology; 

Figure 1 - New Knowledge Coach Workpaper 
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• Knowledge-Based Audit documents, integral to the risk assessment and overall audit processes, which contain steps and 
procedures required by U.S. GAAS, GAGAS, and OMB Circular A-133 when applicable; 

• Customizable Audit Programs that take auditors through related steps and procedures; 

• Practice Aids to help auditors complete steps or processes outlined in the Knowledge-Based Audit documents and Audit Programs; 

• Auditor’s Reports that provide a variety of sample auditor’s opinions on audited financial statements; and 

• Correspondence documents that provide sample letters to be used to comply with U.S. GAAS, GAGAS, and OMB Circular A-133 
requirements and in many other common situations. 

• The AICPA’s Auditing Standards Board’s (ASB) Risk Assessment Standards - The practice aids and tools in the 2017 Knowledge-Based 
Audits of Governmental Entities are designed around the AICPA’s risk assessment and clarified standards to assist auditors of 
governmental entities by: 

– Facilitating compliance with GAAS, GAGAS, and U.S. Office of Management and Budget (OMB) Circular A-133 (OMB Circular 
A-133); 

– Encouraging more effective audits through tailored audit programs and comprehensive practice aids;  

– Helping auditors to focus on and respond to identified audit risks; and 

– Enhancing audit documentation. 

CCH® ProSystem fx® Knowledge Coach 

Knowledge Coach functionality allows auditors to use the Knowledge-Based-Audit methodology more efficiently by eliminating the need for 
duplicate entry of the same information, tailoring audit documentation to each particular engagement, and documenting the link between 
risks identified and procedures performed. AUD-100 Tailoring Question Workpaper is a document in Knowledge Coach that presents 
engagement-level questions designed to aid in tailoring the engagement documentation to fit each client. Completing the questions helps 
the auditor avoid duplication and unnecessary workpapers.  

Note: Before you begin your audit, please review the guidance in AUD-101 Overall Audit Program. This workpaper is intended to be your 
road map through a Knowledge-Based Audit methodology. You should start your audit with AUD-100 Tailoring Question Workpaper and 
AUD-101 Overall Audit Program. 

• Risks 
can be captured via the Risk Summary task pane from any Knowledge Coach workpaper by the current editor of KBA-502 Summary 
of Risk Assessments. This allows the user to continuously assess risks during the engagement. Several workpapers prompt the 
consideration of the presence of risks, but the Risk Summary task pane must be used to document those risks. All documented risks 
flow to the Risk Summary. To ensure risks show in findings tables, make sure to check the workpaper identified in field of the Risk 
pane. 

• Information Flow 
Helps cut down on the time spent duplicating information across forms. In addition, the flow of consistent information ensures that 
information and updates to information are not missed between workpapers. Drill-down functionality helps the user navigate 
quickly to the source of the information, aiding in the review of the audit file. 

• Diagnostics 
Help keep track of unresolved issues like unanswered questions, incomplete risks, program steps not linked to risks or relevant 
assertions, missing workpaper, and more.  

• Links to Accounting Research Manager (ARM) 
If you subscribe to an ARM library that includes audit content, you can link directly to source material from Resources within 
Knowledge Coach workpapers. These links have been updated to reference to the accounting standards under the FASB Accounting 
Standards Codifications and the auditing standards issued by the AICPA. Also, if you subscribe to the Knowledge-Based Audits of 
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Governmental Entities Guide on ARM, you can take advantage of links to the audit guide material from within the Knowledge Coach 
documents. 

• Interpretive Guidance 
It is integrated into each Knowledge Coach template through the Tips view of each new task pane. Informational features include 
Practice Points, Examples, Optional Workpapers, and Resources to help auditors work more effectively and efficiently. You can also 
navigate from Resources within a document or the tip pane directly to CCH’s Accounting Research Manager and industry audit 
guides by simply clicking on the Reference.  

 

Download Description: 2017 Knowledge-Based Audits of Governmental Entities (5/4/2017) 

Version: Engagement v7.5 with Knowledge Coach v2.5 or higher and 2016 Financial Statement Base v4 

Release Date: May 2017 

File size: 18MB 

Approx. Download Time: 42 minutes at 56 kbps 

License: Full Version 

Platforms: Windows® 7, 8, 8.1, 10 

Office: Microsoft® Office 2010 or higher required 
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